Operadores Aritmeticos

Operador aritmético é o conjunto de símbolos que representa as operações básicas da matemática.

algoritmo"Soma"
var
a, b, soma: inteiro

escreva ("Entre com os valores para A e B")
leia(a,b)
soma <- (a+b)
escreval("A soma da variável A com a variável B é: ", soma)
fimalgoritmo

OBS.:A diferença entre escreva e escreval. Esta, tem a função de "quebrar" linha, enquanto aquela, de manter o texto na mesma linha. Outro ponto importante na ferramenta visualg é que após o fim de cada comando não precisamos colocar dois pontos, como na linguagem C, pois do contrário acarretará erro. Além disso, o visualg não reconhece nome de função, procedimento ou variável acentuadas.

algoritmo"Subtracao"
var
a, b, subtracao: inteiro

escreva ("Entre com os valores para A e B")
leia(a,b)
subtracao <- (a-b)
escreval("A subtração da variável A com a variável B é: ", subtracao)
fimalgoritmo

algoritmo"Multiplicacao"
var
a, b, multiplicacao: inteiro

escreva ("Entre com os valores para A e B")
leia(a,b)
multiplicacao <- (a*b)
escreval("O produto da variável A com a variável B é: ", multiplicacao)
fimalgoritmo

algoritmo"Divisao"
var
a, b, divisao: inteiro

escreva ("Entre com os valores para A e B")
leia(a,b)
divisao <- (a/b)
escreval("A divisão da variável A com a variável B é: ", divisao)
fimalgoritmo

Para representar as operações de radiciação e potenciação no visualg, usaremos as palavras-chave raizq e exp. Conforme exemplificado abaixo:

algoritmo"Raiz quadrada"
var
a, raiz: real

escreva ("Digite o valor para A")
leia(a)
raiz <- raizq(a)
escreval("A raiz quadrada de ", a , " é: ", raiz)
fimalgoritmo

algoritmo"Potenciação"
var
a, expoente: real

escreva ("Digite o valor para A")
leia(a)
expoente <- exp(a,2) //"a" é a base e o "2" o expoente.
escreval("O resultado da potenciação é: ", expoente)
fimalgoritmo

Operador de resto e quociente de divisão inteira

Operador Função Exemplos
mod Resto da divisão 9 mod 4 resulta em 1
div Quociente da divisão 9 div 4 resulta em 2

Precedência entre os Operadores aritméticos

Prioridade Operadores
Parênteses mais internos
Pot rad
* / div mod
+ -

Operadores Relacionais

Operador Função Exemplos
= igual a 3 = 3, X = Y
> Maior que 5> 4, X > Y
< Menor que 3 < 6, X < y
>= Maior ou igual a 5 >= 3, X >= Y
<= Menor ou igual a 3 <= 5, X <= Y
<> Diferente de 8 <> 9, X <> Y

Operadores Lógicos

Operador Função
não negação
e conjunção
ou disjunção

Tabelas-verdade

Operador de negação1

A não A
F V
V F

Operador de conjunção2

A B A e B
F F F
F V F
V F F
V V V

Operador de disjunção não-exclusiva3

A B A ou B
F F F
F V V
V F V
V V V

jose carlosjose carlos
Reddit

Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-ShareAlike 3.0 License